Hyper-V Main Menu Disabled

Dec 26, 2012 at 7:03 PM

Using Release 1.0.1 on Hyper-V Server 2012.  As the Administrator, starting the main menu using Start_Corefig.wsf. 

The "Hyper-V Settings..." button is inactive. 

Verified with DISM the "Microsoft-Hyper-V" feature is enabled, and verified Start-Corefig.wsf is setting the variable "HyperVEnabled" to true prior to calling Corefig.ps1.

Verified running "Hyper-V.ps1" from the powershell command line work as expected.

Any suggestions?

Thanks - Bob

 

Coordinator
Dec 26, 2012 at 7:23 PM
Corefig.PS1 has a backup detection routine in the event that it is called directly. That's the first thing I would try:
POWERSHELL .\Corefig.PS1

If that doesn't work, then it could be that the detection routines for MPIO are interfering. Is MultipathIo enabled on your system?


From: [email removed]
To: [email removed]
Date: Wed, 26 Dec 2012 11:04:08 -0800
Subject: Hyper-V Main Menu Disabled [corefig:424603]

From: bobm
Using Release 1.0.1 on Hyper-V Server 2012. As the Administrator, starting the main menu using Start_Corefig.wsf.
The "Hyper-V Settings..." button is inactive.
Verified with DISM the "Microsoft-Hyper-V" feature is enabled, and verified Start-Corefig.wsf is setting the variable "HyperVEnabled" to true prior to calling Corefig.ps1.
Verified running "Hyper-V.ps1" from the powershell command line work as expected.
Any suggestions?
Thanks - Bob

Read the full discussion online.
To add a post to this discussion, reply to this email (corefig@discussions.codeplex.com)
To start a new discussion for this project, email corefig@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com
Dec 27, 2012 at 12:08 PM

Excellent suggestion!!  Using POWERSHELL .\Corefig.PS1 to start CoreFig, the  "Hyper-V Settings..." button is active.  I am able to start/stop VMs and perform the action "Refresh Virtual Machines".  The action "Refresh Thumbnails" generates error messages.

Multipathio is not enabled on this system.

Thanks for the workaround - Bob

Coordinator
Dec 27, 2012 at 1:27 PM
No problem. I'll investigate and see if I can determine why the WSF doesn't perform as it should.

The VM settings screen is all original script from Core Configurator 2.0. All I did on that screen was localize the text. It's on my to-do list to review that but I have no ETA.


From: [email removed]
To: [email removed]
Date: Thu, 27 Dec 2012 04:08:38 -0800
Subject: Re: Hyper-V Main Menu Disabled [corefig:424603]

From: bobm
Excellent suggestion!! Using POWERSHELL .\Corefig.PS1 to start CoreFig, the "Hyper-V Settings..." button is active. I am able to start/stop VMs and perform the action "Refresh Virtual Machines". The action "Refresh Thumbnails" generates error messages.
Multipathio is not enabled on this system.
Thanks for the workaround - Bob
Read the full discussion online.
To add a post to this discussion, reply to this email (corefig@discussions.codeplex.com)
To start a new discussion for this project, email corefig@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com