This project has moved. For the latest updates, please go here.
1

Closed

Firewall Settings not shown correctly - enhance / bug

description

Hi,
Just installed v1.1 of this tool on Hyper-V 2012 Core.
Works great but I wanted to turn all the firewall options OFF (Domain, Private and Public networks) as i'm only using it on a test environment that has limited access.
Obviously I went to the Firewall section of this tool (Control Panel | Firewall | Firewall Settings) and clicked all the radio buttons to turn off each location.
Once applied the statuses still showed a green tick shield and the settings stayed on the 'Turn on' radio button.

I think they actually worked though (I went in an used 'netsh advfirewall set domainprofile state off' to turn that off - I should use powershell but...).
If you look at the Firewall status against the green shield they go from Enabled: True to Enabled: False (or vice versa)... it's the only way to actually see it's worked.

Additionally, I notice that if you choose to expand each network shield using the downarrow button, you can only show two at a time, not all three...

Is it possible to implement a Red, crossed, shield and ensure the radio buttons reflect the status too?

Kind Regards
Andy

file attachments

Closed Mar 20, 2013 at 4:11 PM by ejsiron
Fixed in 1.1.1.

comments

andypalmerpalmer wrote Mar 20, 2013 at 1:12 PM

And a pic of the shields showing green even though they are off.
Only allowed one attachment for some reason...
Andy

ejsiron wrote Mar 20, 2013 at 1:41 PM

I will look into this. Thanks for the report.

ejsiron wrote Mar 20, 2013 at 4:10 PM

Enabling, disabling, and display fixed in 1.1.1.

The display issue will have to wait. All three settings can't be displayed at once due to windows size limitations. I don't really like the way that dialog looks at all and am planning an entire revamp in 2.0.

wrote Mar 20, 2013 at 4:11 PM

wrote May 16, 2013 at 11:33 AM